When installing the DHL Shipping module in version 1.2.0 (or higher), this Composer error message appears:
Your requirements could not be resolved to an installable set of packages.
Can only install one of: dhl/sdk-api-parcel-management[2.0.0, 1.0.0].
This happens when the legacy DHL module 0.11.x is already installed.
The two DHL modules have incompatible dependencies:
- DHL Shipping version 0.11.x (legacy) needs the sdk-api-parcel-management version 1.x.x
- DHL Shipping version 1.2.0 (or higher) needs the sdk-api-parcel-management version 2.x.x
Both SDKs cannot be installed at the same time.
- First, install version 1.1.0 of the DHL Shipping module (not 1.2.0 or higher).
- Make the migration and process all existing orders as described in the documentation of the current module.
- When all old orders have been completely processed (incl. their DHL labels), remove DHL Shipping 0.11.x completely.
- Afterwards, update DHL Shipping 1.1.0 to version 1.2.0 (or higher).