Problem

When creating a shipment, the checkbox "Create shipping labels" is missing.


Checkbox "Create shipping labels"


Possible causes


1.)

The country of the shop is not set correctly (unsupported country).


2.)

The shipping method for the order is not selected in the DHL module configuration.


3.)

The shipping method may not be compatible with DHL Versenden/Shipping. This can happen when using M2E Pro.


4.)

The buyer's address couldn't be detected automatically (splitting street name and house number)


5.)

DHL Easylog is installed on the system (only applies to Magento 1).


6.)

If Magento 2.4.0 is used, this Magento bug might be the cause.


7.)

Table Rates should be used, but the configuration of those is not correct.


Solutions


1.)

Set the shop's country (shipment origin) correctly. The supported countries are listed in the documentation.


2.)

In the configuration of the DHL module, select the shipping method that should be handled by DHL.


3.)

For testing, link the DHL module to a Magento shipping method (e.g. Flat Rate). Then create a new order and try to create a DHL label. If this works, there is most likely an incompatibility. Please contact our support team.


4.)

Click the link "Edit" at the shipping address and correct any mistakes. Make sure to enter the street name and house number separately into the special DHL fields further down on the page. For further details see this article.


5.)

DHL Easylog must be removed completely from the system. Otherwise, it can disrupt the process of DHL Versenden/Shipping (only applies to Magento 1).


6.)

Install this patch - applies only to Magento 2.4.0, see also this information.


7.)

Configure the DHL module to use Flat Rate and test with a new order if a label can be created. If this works, but it doesn't work with Table Rates, the configuration of the Table Rates is most likely the problem.


Important

After resolving the problem, create a new order to test if it works! For the existing orders the checkbox will still not be displayed. Those orders need to be shipped manually via the Business Customer Portal.