Problem

When creating a shipment, the checkbox "Create shipping labels" is missing.


Checkbox "Create shipping labels"


Possible causes


1.)

The DHL module is not enabled in the configuration.


2.)

The country of the shop is not set correctly (unsupported country).


3.)

The shipping method for the order is not selected in the DHL module configuration.


4.)

The shipping method may not be compatible with DHL Versenden/Shipping. This can happen when using M2E Pro.


5.)

The buyer's address couldn't be detected automatically (splitting street name and house number)


6.)

If Magento 2.4.0 is used, this Magento bug might be the cause.


7.)

Table Rates should be used, but the configuration of those is not correct.


Solutions


1.)

Check the configuration "Enabled - Allow customers to check out with DHL Paket shipping methods". This mus be enabled.


2.)

Set the shop's country (shipment origin) to Germany, see this article.


3.)

In the configuration of the DHL module, select the shipping method that should be handled by DHL. If multiple shipping methods should be processed via DHL, the module-carrier-update can be installed in addition to DHL Shipping 2.x.


4.)

For testing, link the DHL module to a Magento shipping method (e.g. Flat Rate). Then create a new order and try to create a DHL label. If this works, there is most likely an incompatibility.


The DHL Shipping module is not officially compatible with M2E Pro. Users of M2E Pro can implement a custom solution based on this Github issue.


5.)

Click the link "Edit" at the shipping address and correct any mistakes. Make sure the street name and house number are correct.


6.)

Install this patch - applies only to Magento 2.4.0, see also this information.


7.)

Configure the DHL module to use Flat Rate and test with a new order if a label can be created. If this works, but it doesn't work with Table Rates, the configuration of the Table Rates is most likely the problem.


Important

After resolving the problem, the checkbox may still not be displayed for existing orders. Those orders need to be shipped manually via the Business Customer Portal.