Problem
Bei Erstellung eines Lieferscheins fehlt die Checkbox "Paketaufkleber erstellen" (Create Shipping Label).
Mögliche Ursachen
1.)
Das DHL-Modul ist in der Konfiguration nicht aktiviert.
2.)
Das Absenderland des Shops ist nicht korrekt eingestellt (nicht unterstütztes Land).
3.)
Die Versandart der Bestellung ist in der Konfiguration nicht mit der DHL-Extension verknüpft.
4.)
Die Versandart ist nicht kompatibel mit DHL Versenden/Shipping. Dies kann z.B. bei Nutzung von M2EPro der Fall sein.
5.)
Die Versandadresse ist unvollständig (z.B. Trennung von Straße und Hausnummer).
6.)
Bei Nutzung von Magento 2.4.0 kann ein Magento-Bug die Ursache sein.
7.)
Die Konfiguration der Table Rates (Tabellenbasierte Versandkosten) ist nicht korrekt (sofern verwendet).
Lösungen
zu 1.)
Prüfen Sie die Einstellung "Aktiviert - DHL Paket als Versandart im Checkout anbieten" im Modul. Diese muss eingeschaltet sein.
zu 2.)
Das Absenderland des Shops (Versandursprung) muss auf Deutschland eingestellt sein, siehe auch dieser Artikel.
zu 3.)
Wählen Sie in der Konfiguration des DHL-Moduls die Versandart, die über DHL abgewickelt werden soll. Falls mehrere Versandarten über DHL abgewickelt werden sollen, kann das Modul module-carrier-update zusätzlich zu DHL Shipping 2.x installiert werden.
zu 4.)
Stellen Sie testweise eine Magento-Offline-Versandart (z.B. Flat Rate/Festpreis) im DHL-Modul ein. Erstellen Sie dann eine neue Bestellung und testen Sie, ob dafür ein DHL-Label erstellt werden kann. Wenn ja, liegt sehr wahrscheinlich eine Inkompatibilität vor.
Das DHL Shipping-Modul ist offiziell nicht mit M2E Pro kompatibel. Nutzer von M2E Pro können anhand dieses Github-Issues eine eigene Lösung implementieren.
zu 5.)
Klicken Sie auf den Link "Bearbeiten" an der Lieferadresse und korrigieren Sie unrichtige Adressangaben. Achten Sie insbesondere auf Straße und Hausnummer.
zu 6.)
Installieren Sie diesen Patch - betrifft nur Magento 2.4.0, siehe auch dieser Artikel.
zu 7.)
Stellen Sie testweise die Versandart Flat Rate/Festpreis im DHL-Modul ein und testen Sie mit einer neuen Bestellung, ob das Label erstellt werden kann. Wenn es dann funktioniert, jedoch nicht mit Table Rates, liegt das Problem höchstwahrscheinlich in der Konfiguration der Table Rates.
Wichtig
Nach Behebung des Fehlers wird bei den bereits existierenden Bestellungen die Checkbox evtl. weiterhin nicht angezeigt. Die Label müssen dafür über das Geschäftskundenportal angelegt werden.