Problem

Bei Erstellung eines Lieferscheins fehlt die Checkbox "Paketaufkleber erstellen" (Create Shipping Label).




Mögliche Ursachen


1.)

Das Absenderland des Shops ist nicht korrekt eingestellt (nicht unterstütztes Land).


2.)

Die Versandart der Bestellung ist in der Konfiguration nicht mit der DHL-Extension verknüpft.


3.)

Die Versandart ist nicht kompatibel mit DHL Versenden/Shipping. Dies kann z.B. bei Nutzung von M2E Pro der Fall sein.


4.)

Die Adresse des Käufers konnte nicht korrekt erkannt werden (z.B. Trennung von Straße und Hausnummer).


5.)

Auf dem System ist DHL Easylog installiert (betrifft nur Magento 1).


6.)

Bei Nutzung von Magento 2.4.0 kann ein Magento-Bug die Ursache sein.


7.)

Es sollen die Table Rates verwendet werden, aber deren Konfiguration ist nicht korrekt.


Lösungen


zu 1.)

Das Absenderland des Shops (Versandursprung) muss korrekt eingestellt sein. Die unterstützten Länder stehen in der Dokumentation.


zu 2.)

Wählen Sie in der Konfiguration des DHL-Moduls die Versandart, die über DHL abgewickelt werden soll.


zu 3.)

Verknüpfen Sie testweise eine Magento-Versandart (z.B. Flat Rate) mit DHL. Erstellen Sie dann eine neue Bestellung und testen Sie, ob ein DHL-Label erstellt werden kann. Wenn ja, liegt sehr wahrscheinlich eine Inkompatibilität vor. Bitte kontaktieren Sie unser Support-Team.


zu 4.)

Klicken Sie auf den Link "Bearbeiten" an der Lieferadresse und korrigieren Sie unrichtige Adressangaben. Achten Sie darauf, die Straße und Hausnummer weiter unten in den gesonderten Feldern für DHL korrekt einzutragen, wie in diesem Artikel erklärt.


zu 5.)

DHL Easylog muss komplett deinstalliert werden. Es stört sonst den Prozess von DHL Versenden/Shipping (betrifft nur Magento 1).


zu 6.)

Installieren Sie diesen Patch - betrifft nur Magento 2.4.0, siehe auch dieser Artikel.


zu 7.)

Stellen Sie testweise die Versandart Flat Rate (Festpreis) im DHL-Modul ein und testen Sie mit einer neuen Bestellung, ob das Label erstellt werden kann. Wenn es so funktioniert, jedoch nicht mit Table Rates, liegt das Problem höchstwahrscheinlich in der Konfiguration der Table Rates.


Wichtig 

Nach Behebung des Fehlers erstellen Sie zum Testen eine neue Bestellung! Bei den bereits existierenden Bestellungen wird die Checkbox weiterhin nicht angezeigt werden. Diese müssen bei Bedarf über das Geschäftskundenportal angelegt werden.