Problem
Bei der Label-Erstellung erscheint die Meldung "hard validation error".
Beispiel im Browser:
Beispiel im Log:
Ursache
Diese Meldung wird vom DHL-Webservice ausgegeben, wenn eine oder mehrere Angaben zur Sendungserstellung falsch sind oder fehlen.
Lösung
Prüfen Sie die weiteren in der Fehlermeldung genannten Angaben. Es können mehrere Angaben betroffen sind. Einige Beispiele:
Die ausgewählte Abrechnungsnummer steht nicht zur Verfügung
Prüfen Sie anhand dieser Anleitung, ob die EKP und Teilnahmenummern korrekt und vollständig in Magento eingerichtet sind.
Der angegebene Service ist nicht bekannt
Es wurde ein Zusatzservice genutzt, der im DHL-Account nicht freigeschaltet ist (z.B. Beilegerretoure, Alterssichtprüfung, etc.). Nehmen Sie Kontakt mit DHL auf, um den Service für Ihre Abrechnungsnummer freischalten zu lassen, oder wählen Sie den Service während der Label-Erstellung manuell ab.
Das angegebene Produkt ist nicht bekannt
Es wurde ein DHL-Produkt (Verfahren) gewählt, das im DHL-Account nicht freigeschaltet ist. Prüfen Sie die Konfiguration der Teilnahmenummern in Magento. Wenn das nicht hilft, kontaktieren Sie DHL und bitten Sie um Prüfung der Freischaltung der Produkte (Verfahren) in Ihrem Vertrag.
Die eingegebene Adresse ist nicht leitcodierbar
Die Empfänger- oder Absenderadresse enthält falsche Angaben oder es fehlen Teile davon (Details siehe unten).
Bitte geben Sie eine Hausnummer an
Prüfen Sie, ob die Hausnummer eingegeben wurden. Es muss ein Leerzeichen zwischen Straße und Hausnummer stehen. Korrigieren Sie ggf. die Lieferadresse in Magento von Hand und tragen Sie Straße und Hausnummer in die korrekten Felder ein.
Es handelt sich um eine ungültige Postleitzahl
Prüfen Sie, ob die Postleitzahl tatsächlich zur Straße, Hausnummer und Stadt passt. Beachten Sie, dass sehr lange Straßen ggf. mehrere Postleitzahlen haben können. Prüfen Sie mit Google Maps, ob die Adresse plausibel ist.
Die angegebene Straße kann nicht gefunden werden
Prüfen Sie mit Google Maps, ob die Straße und Hausnummer in der genannten Stadt und dem Postleitzahlgebiet wirklich existieren.
Bitte geben Sie eine Postnummer an
Für bestimmte Sendungen (z.B. an Packstationen) ist die Angabe der Postnummer verpflichtend. Prüfen Sie, ob die Postnummer vorhanden ist und im korrekten Feld steht (Feld "Postnummer" oder alternativ Feld "Firma").
Die verwendete Postnummer ist nicht gültig
Die Postnummer enthält einen Eingabefehler. Setzen Sie sich mit dem Empfänger in Verbindung, um die korrekte Nummer zu erfahren.
Bitte geben Sie ein Gewicht an
Es muss ein Sendungsgewicht angegeben werden. Standardmäßig werden die Artikelgewichte der Bestellung verwendet. Stellen Sie sicher, dass im Produktkatalog in Magento die Artikelgewichte korrekt eingetragen sind, damit diese automatisch an DHL übertragen werden können.
Die Gewichtsangabe ist zu gering
Das Mindestgewicht der Sendung wurde unterschritten. Erhöhen Sie die Angabe auf mind. 0,2 kg.
Die Gewichtsangabe ist zu hoch
Teilen Sie die Bestellung in mehrere Lieferungen auf, um das Maximalgewicht (31,5 kg je Paket) nicht zu überschreiten.
Bitte geben Sie die Art der Sendung an. Bitte geben Sie die Anzahl an. Bitte geben Sie die Beschreibung an. Bitte geben Sie den Warenwert an
Für das Zielland sind Zollpapiere erforderlich, welche hier jedoch fehlen. Prüfen Sie in der Magento-Konfiguration, ob das Zielland korrekt als EU-/Nicht-EU-Land eingestellt ist. In seltenen Einzelfällen muss das Label von Hand im DHL Geschäftskundenportal erstellt werden.