Problem

Bei der Label-Erstellung erscheint die Meldung "hard validation error".


Ursache

Diese Meldung wird direkt vom DHL-Server ausgegeben und kann verschiedene Ursachen haben.

  • Der Wert eines bestimmten Feldes in den Sendungsdaten ist ungültig (zu viele Zeichen, Zahl zu klein oder zu groß, ungültiges Format, etc.).
  • Ungültige Adressangaben (z.B. Straße passt nicht zu PLZ usw.). DHL prüft die Adresse auch im Test- / Sandbox-Modus auf Korrektheit (Stichwort Leitcodierung).
  • Evtl. liegt auch eine Fehlkonfiguration vor (z.B. falsche Adresse in Magento konfiguriert).


"Hard validation error" wegen

ungültiger PLZ für den Ort



Lösungen

  1. Prüfen Sie, ob zusätzlich zu der Meldung auch der Name des betroffenen Feldes erscheint (z.B. Straße, Hausnummer, PLZ). Korrigieren Sie fehlerhafte Angaben über den "Bearbeiten"-Button der Lieferadresse.
  2. Das Sendungsgewicht kann zu gering sein, siehe dieser FAQ-Artikel.
  3. Wenn das Problem im Zusammenhang mit Retouren auftritt, beachten Sie bitte diesen FAQ-Artikel.
  4. Falsche Teilnahmenummern können ebenfalls zu diesem Fehler führen, siehe dieser FAQ-Artikel.
  5. Prüfen Sie die Logdatei des Moduls. Suchen Sie darin nach dem Begriff "error key" oder "status message". Dort wird angezeigt, welche Angaben bzw. Felder fehlerhaft waren.


Beispiel Logdatei